Easter Day & Labour Day Sale: 35% OFF on Storewide!
0
Your Cart is currently empty!
Product update
Coupon
add
Coupon code invalid! Please re-enter!
AJAX loader
You are here: HomeForum

We are here to serve :)

Our support team is currently online to solve your issues.

Our support team is currently offline

Our support heroes might not be around this hour. Please expect some delays.

Our support is available from

Monday - Friday 8am - 5:30pm GMT+7

Your time: 00:00:00
Our time: 00:00:00

Welcome, Guest

SJ Shoppystore 2.1.1 - Shame on your products
(1 viewing) (1) Guest
  • Page:
  • 1
  • 2

TOPIC: SJ Shoppystore 2.1.1 - Shame on your products

SJ Shoppystore 2.1.1 - Shame on your products 2 years, 3 months ago #31238

Well, I am not surprise about the fact your products are bad.
All your products don't support PHP7

I just installed the quickstart and there are many many errors:

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; plgSystemX_Menu_Params has a deprecated constructor in ~/plugins/system/x_menu_params/x_menu_params.php on line 6

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; plgSystemRegacymailing has a deprecated constructor in ~/plugins/system/regacymailing/regacymailing.php on line 12

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Plugin_googleMaps has a deprecated constructor in ~/plugins/system/ytshortcodes/includes/libs/googlemap/googleMaps.lib.php on line 366

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; plgSystemEUCookieDirectiveLite has a deprecated constructor in ~/plugins/system/EUCookieDirectiveLite/EUCookieDirectiveLite.php on line 37

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; plgSystemJw_disqus has a deprecated constructor in ~/plugins/system/jw_disqus/jw_disqus.php on line 19

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; YtFrameworkTemplate has a deprecated constructor in ~/plugins/system/yt/includes/site/lib/yt_template.php on line 16

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; YtFrameworkRenderXML has a deprecated constructor in ~/plugins/system/yt/includes/site/lib/yt_renderxml.php on line 13

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; YtObject has a deprecated constructor in ~/templates/sj_shoppystore/menusys/ytobject.php on line 13

Today, Joomla and the major components, plugins, templates are working with PHP7 but not your product.

Please, you have to inform your customers correctly on your products.
I bought SJ Shoppystore because I red "works with PHP5 and PHP7" but it's wrong. I asked for a refund and you said no. I was waiting for an update and your update doesn't work for me.

Now I can say: "Shame on you" for selling very bad products to your customers

Re: SJ Shoppystore 2.1.1 - Shame on your products 2 years, 3 months ago #31254

Dear toto13,

Please go to admin >> Global Configuration >> Sever >> Set Simple in 'Error Reporting' or go to your PHP.ini file in your sever and set:
error_reporting = E_ALL & ~E_NOTICE & ~E_DEPRECATED

Thanks

Re: SJ Shoppystore 2.1.1 - Shame on your products 2 years, 3 months ago #31255

For what ? Hiding these errors ?
Sorry I don't work like this. These errors could have some compatibility errors on plugins or components. It's not a good job to work like this.

I don't get these errors with other template providers.

Re: SJ Shoppystore 2.1.1 - Shame on your products 2 years, 3 months ago #31280

Dear toto13

Thanks for your information.
We're updating and testing this issue and inform to you as soon as.

Thanks.

Re: SJ Shoppystore 2.1.1 - Shame on your products 2 years, 2 months ago #31828

I have the same problem with ytshorcodes; the site was working fine a month ago and now I am havind this issue:
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; Plugin_googleMaps has a deprecated constructor in /home/myfolder/public_html/mywebsite/plugins/system/ytshortcodes/includes/libs/googlemap/googleMaps.lib.php on line 366

I cannot access the backend, once I login I get an error:
An error has occurred.
Failed to start the session because headers have already been sent by "/home/myfolder/public_html/mywebsite/plugins/system/ytshortcodes/includes/libs/googlemap/googleMaps.lib.php" at line 366.
and redirects to login page again.

Re: SJ Shoppystore 2.1.1 - Shame on your products 2 years, 2 months ago #31832

Dear dhacohen

I fixed this issue in /plugins/system/ytshortcodes/includes/libs/googlemap/googleMaps.lib.php and find:

function Plugin_googleMaps( &$row, $pluginParams, $is_mod=0 ) {

=> change to:

function __construct( &$row, $pluginParams, $is_mod=0 ) {

please refer: cweiske.de/tagebuch/php4-constructors-php7.htm

Thanks
  • Page:
  • 1
  • 2
Time to create page: 0.48 seconds

Notification

Please find your issue via Suggested Posts before submitting your question. We have solved the most of issues and maybe your issue was solved before.

Suggested Posts

(/)
Result not found!

Latest My Topics

No posts to display.

Love all our templates?

Join our membership clubs starting at $49 only for access to all of our templates

Join Now
Magento Themes Magento Extensions Free Magento Extensions Prestashop Themes Prestashop Modules Magento 2 Themes