CRAZY Halloween Deal: 45% OFF for All Products & Subscriptions
0
Your Cart is currently empty!
Product update
Coupon
add
Coupon code invalid! Please re-enter!
AJAX loader
You are here: HomeBlogNews & UpdatesJoomla 3.1 Beta1 released
March.08.2013

Joomla 3.1 Beta1 released

Tagged under:

It’s a pleasure when receiving news of Joomla “JOOMLA 3.1 BETA1 RELEASED” and if all goes well, Joomla 3.1 will be released on schedule (around March 25th, 2013).

wordpress blog

 

 

Developers are encouraged to work with this release to prepare extensions for Joomla 3.1 and NOT recommended to use on production sites. Community members are asked to install the package in order to provide quality assurance for Joomla 3.1. All problems about issues, users can report in the Joomla! issue tracker.

What's new?

29855 - Tags

29822 - Show logs in debug console

30085 - Refactor installation to use new application and MVC classes

29965 - Add pagination in COM_SEARCH component

29770 - Added triggers on save for com_config

Miscellaneous: 28574 - Removed the GeSHi plug-in

DOWNLOAD JOOMLA 3.1 BETA.

What’s the status of Joomla! 1.5 and Joomla! 2.5?

Joomla 2.5:

Joomla 2.5 is a long-term support version and its support will expire shortly after the release of the next long-term support version - Joomla 3.5. This is scheduled to happen sometime during the spring of 2014.

Sites that are still running on Joomla 2.5 are encouraged to stay on 2.5 until Joomla 3.5’s release; many plugins that are Joomla 2.5 compatible will work with Joomla 3 without the need of any changes unless you want to move to take advantage of Joomla 3.x’s new features. Converting from Joomla 2.5 to the version 3.x will be a mini-migration not an upgrade. It’s just a one-click upgrade from Joomla 2.5 to any Joomla 3 version.

Please read the Joomla 3.0 Frequently Asked Questions for more information.

Make sure you create a full backup of your site before you start the upgrade process. You can use our How to Backup a Joomla 2.5 Site tutorial if you need help with creating a backup.

Joomla! 1.5:

Joomla has stopped support for the CMS Joomla 1.5 in April 2012. Major security fixes will be done until the release of Joomla 3.0 in September 2012.

This means that after September 2012:

No more updates
No possibility to download via http://www.joomla.org
No longer supported by the developer security updates
No more support will be given via forums or other channels.
If you wish to add extensions to your existing site, you may have difficulty because the Joomla extension developers are now only supporting Joomla 2.5 and 3.0.

If you are using Joomla 1.5 then we strongly recommend migrating to Joomla 2.5. This is not simple to go from 1.5 to 2.5 or 3.0; however, you can use two good extensions jUpgrade and SPUpgrade to do this job easier. You have a choice of going straight to Joomla 3.0 or going to 2.5 first, both jUpgrade and SPUpgrade have versions ready for both versions.

In order to beginning a new site, the Joomla! 3.x is the preferred series with new features and more advanced security. Joomla! 3.x also provides you with longer backward compatible support than starting a new site on 2.5 right now.

Our Products:

Please click HERE to explore new experiences of our products that support Joomla 2.5 and Joomla 3.0!

Thanks for reading!

Love all our templates?

Join our membership clubs starting at $49 only for access to all of our templates

Join Now
Magento Themes Magento Extensions Free Magento Extensions Prestashop Themes Prestashop Modules Magento 2 Themes

H A L L O W E E N S A L E!

45% OFF

Everything at SmartAddons

Code: SPOOKY19