Happy Halloween! 25% OFF Discount Coupon Code for Everything!
My Cart (0 item)
Your Cart is currently empty!
Product update
Coupon
add
Coupon code invalid! Please re-enter!
AJAX loader
You are here: HomeBlogTutorials and Case studiesHow to Fix Bugs, Errors When Update Sj Templates to Joomla 3.8
September.26.2017

How to Fix Bugs, Errors When Update Sj Templates to Joomla 3.8

Howdy friends!

As Joomla 3.8 release with New Routing System and Joomla 4 Compatibility Layer, we've started to update our Joomla products to this latest Joomla release. However, it may takes several weeks for us to complete the update. Do not let you wait too long, we would like to share you the instruction to fix SmartAddons Templates when updating to Joomla 3.8. Now you can update SJ Templates to Joomla 3.8 by yourself.

How to Fix Bugs, Errors When Update Sj Templates to Joomla 3.8

Fix bugs, Errors for SJ Templates on Joomla 3.8

1. YT Shortcode Error

How to Fix Bugs When Update Sj Templates to Joomla 3.8

Fix:

- Re-install YT Shortcode version 3.0.4

2. mod_login Error

How to Fix Bugs When Update Sj Templates to Joomla 3.8

Fix:

- Go to: html/mod_login/default.php

- Find this code:

$document       = &JFactory::getDocument();

- Remove '&' characte:

$document       = JFactory::getDocument();

3. Sj Contact Ajax Error

How to Fix Bugs When Update Sj Templates to Joomla 3.8

Fix:

- Go to: modules\mod_sj_contact_ajax\mod_sj_contact_ajax.php

- Find this code:

$layout = $params->get('layout', 'default');
$cacheid = md5(serialize(array($layout, $module->id)));
$cacheparams = new stdClass;
$cacheparams->cachemode = 'id';
$cacheparams->class = 'ContactAjax';
$cacheparams->method = 'getList';
$cacheparams->methodparams = $params;
$cacheparams->modeparams = $cacheid;
$list = JModuleHelper::moduleCache($module, $params, $cacheparams);

- Edit to

$layout = $params->get('layout', 'default');
$list = ContactAjax::getList($params);

OR

$layout = $params->get('layout', 'default');
$list = ContactAjax::getList($params, $module->id);

4. mod_sppagebuilder_admin_menu Error

How to Fix Bugs When Update Sj Templates to Joomla 3.8

Fix:

- Please refer Joomshaper forum here.

5. Countdown Error in Coming Soon Page

How to Fix Bugs When Update Sj Templates to Joomla 3.8

Fix:

- Go to: templates\sj_imovie\comingsoon.php (Sj iMovie as example)

- Find this code:

JHtml::_('jquery.framework');

- Add this code:

JHtml::_('bootstrap.framework');

=>

//Load jQuery
JHtml::_('jquery.framework');
JHtml::_('bootstrap.framework');

6. 404 Error When Using Helix Framework

How to Fix Bugs When Update Sj Templates to Joomla 3.8

Fix:

- Open file: templates\sj_imovie\error.php (Sj iMovie as example)

- Find this code:

require_once(JPATH_LIBRARIES.'/joomla/document/html/renderer/head.php');

- Replace by:

require_once(JPATH_LIBRARIES.'/src/document/renderer/html/HeadRenderer.php');

Or remove it.

Fix Bugs, Errors on SJ Template Using YT Framework on PHP7 & Https

1. Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP

Fix:

- Go to error file and find this code:

function qwis_facebook_widget() {

- Replace by:

function __construct() {

2.Warning: Illegal string offset 'relative' in \libraries\src\HTML\HTMLHelper.php

Fix:

- Re-define css & js files

- In error files, find this codes:

JHtml::script(JUri::base()."plugins/system/ytshortcodes/shortcodes/content_slider/js/content_slider.js");

JHtml::stylesheet(JUri::base()."plugins/system/ytshortcodes/assets/css/animate.css",'text/css',"screen");

JHtml::stylesheet(JUri::base()."plugins/system/ytshortcodes/shortcodes/content_slider/css/content_slider.css");

Replace by:

JHtml::_('script', JUri::base()."plugins/system/ytshortcodes/shortcodes/content_slider/js/content_slider.js");

JHtml::_('stylesheet', JUri::base()."plugins/system/ytshortcodes/assets/css/animate.css");

JHtml::_('stylesheet', JUri::base()."plugins/system/ytshortcodes/shortcodes/content_slider/css/content_slider.css");

3. Error Warning Php7 in Core VirtueMart

Fix:

Change: Error Reporting = none

4. Enable Force HTTPS

Errors occur in Google_font and mod_sj_vm_listing_tabs

Fix:

- Go to: templates\sj_revo\includes\bottom.php

- Find this code:

$doc->addStyleSheet('https://fonts.googleapis.com/css?family='.$font.'&subset=latin,latin-ext');

- Replace by:

if(isset($_SERVER['HTTPS'] )){
$doc->addStyleSheet('https://fonts.googleapis.com/css?family='.$font.'&subset=latin,latin-ext');
}else{
$doc->addStyleSheet('http://fonts.googleapis.com/css?family='.$font.'&subset=latin,latin-ext');
}

- Go to: templates\sj_revo\html\mod_sj_vm_listing_tabs/default.php

- Remove line code :

JHtml::stylesheet('http://fortawesome.github.io/Font-Awesome/assets/font-awesome/css/font-awesome.css');

Our team have been starting to update all our Free and Premium Joomla templates and Professional Joomla Extensions to Joomla 3.8. If you've already updated Sj Templates to Joomla 3.7.5, you can smoothly update to Joomla 3.8. For others, please wait for our update release.

Besides, we will have an instruction blog for guiding you to update SJ Templates to Joomla 3.8. So, keep in touch with us for the good news!

Love all our templates?

Join our membership clubs starting at $49 only for access to all of our templates

Join Now

Join Affiliate Program

Join SmartAddons Affiliate Program

Earn money with SmartAddons!
Get paid immediately.
Up-to 30% of every sale

Join Affiliate Program